summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPumpkinCheshire2022-05-24 12:25:05 +0800
committerPumpkinCheshire2022-05-24 12:25:05 +0800
commit89d15f41d4fa7d49e290dff1f95ba675c4647993 (patch)
tree13b3f47268246cec4452794f35008a4558a1bb9a /PKGBUILD
parentb94a7b4bd3cc0d51548f77d76788671ed7e0b314 (diff)
downloadaur-python-amazon.ion.tar.gz
bump to 0.9.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aaaa25777102..cd7359d7fb02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname="python-amazon.ion"
_name="amazon.ion"
-pkgver=0.9.1
+pkgver=0.9.2
pkgrel=1
pkgdesc='A Python implementation of Amazon Ion.'
url='https://amzn.github.io/ion-docs/'
@@ -14,17 +14,23 @@ depends=(
'python-py'
'python-six'
)
+makedepends=(
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-b2sums=('290f8bf8417bbccdf7a0b48449f6e435cbf5950c5ba11c8e71656eb9ee03520281d310079947fa4a05f02c0b26443f9c5b42d6eac4c84e3c789ba0ab1450e28b')
+b2sums=('a7ca5d4d81f16c7951679249850c57def9d315a4b904fc248d55823d993c6141b58e963e12f7f3a2f6d35caba58618baf48e243dc3c922c05926763a4c36a7d4')
build() {
cd "$srcdir/$_name-$pkgver" || exit
- export PYTHONHASHSEED=0
- python setup.py build
+
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$_name-$pkgver" || exit
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ # install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/python-$_name/LICENSE"
}