summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel Magno2021-05-04 20:11:19 -0300
committerGabriel Magno2021-05-04 20:11:19 -0300
commit54f678e30a021cc56a5489a4d758c87fc8a6e6b4 (patch)
treedb9cd12b6cf107e00123adbb5674540d2fd3586d /PKGBUILD
parent19d4dd05318c871e9a32bee383fccf946fd08783 (diff)
downloadaur-python-awesome-slugify.tar.gz
Modernized the PKGBUILD to utilize the build function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9189362ca7e6..a7f7cad632f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=awesome-slugify
pkgname=python-$_pkgname
pkgver=1.6.5
-pkgrel=1
+pkgrel=2
pkgdesc="Flexible slugify function"
arch=('any')
url="https://github.com/dimka665/awesome-slugify"
@@ -13,12 +13,17 @@ depends=('python'
'python-unidecode'
'python-nose')
source=("https://pypi.python.org/packages/34/39/79ef4e640c3651b40de7812f5fcd04698abf14de4f57a81e12b6c753d168/$_pkgname-$pkgver.tar.gz")
+sha256sums=('bbdec3fa2187917473a2efad092b57f7125a55f841a7cf6a1773178d32ccfd71')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}
-sha256sums=('bbdec3fa2187917473a2efad092b57f7125a55f841a7cf6a1773178d32ccfd71')
# vim:set ts=2 sw=2 et: