summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2023-07-11 11:34:52 -0300
committerDanilo J. S. Bellini2023-07-11 11:34:52 -0300
commit888424d47292f9b3b0c162ab8d82a73c0ac4fc7c (patch)
tree2d364cbbd68627549e56deee7eb9b78dd065d1aa /PKGBUILD
parent0a3373743a5c0474468103d04a983454efbd0166 (diff)
downloadaur-python-axelrod.tar.gz
v4.13.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f613f38dbe7..9ad29a96c7cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('python-axelrod')
-pkgver=4.12.0
+pkgver=4.13.0
pkgrel=1
pkgdesc="Research tool for the Iterated Prisoner's Dilemma"
arch=('any')
url='https://github.com/Axelrod-Python/Axelrod'
license=('MIT')
checkdepends=('python-hypothesis')
-makedepends=('python-setuptools')
-depends=('python-dask'
- 'python-matplotlib' 'python-numpy' 'python-pandas'
- 'python-prompt_toolkit' 'python-yaml' 'python-scipy'
- 'python-tqdm')
+makedepends=('python-setuptools' 'python-prompt_toolkit')
+depends=('python-dask' 'python-matplotlib' 'python-numpy' 'python-pandas'
+ 'python-yaml' 'python-scipy' 'python-tqdm')
+optdepends=('python-prompt_toolkit: enable the Human strategy')
options=(!emptydirs)
-sha256sums=('5360e7e52a8fdf8e2f8af5e59f4e0fb54f11f245103ed77be91f854e6848b019')
+sha256sums=('b0e1f58c3220bd6e8fb2ce8bf60e35c785dbeaa32e82e0d23361fd7bd7267e60')
source=("$pkgname-v$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
prepare() {
cd "$srcdir/Axelrod-$pkgver"
- # Avoid installing optional/unrequired dependencies
- echo > "requirements.txt"
+ # No longer necessary but avoids messing with dask dependencies
+ echo > "requirements/requirements.txt"
}
check() {