summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:39:56 -0700
committerKelsey Maes2017-05-01 22:39:56 -0700
commit9eaca030134008b39c4afbc94245b575d7ee92fa (patch)
tree7c53d06a5743f57241c191d66a42bb4ce9ddb237 /PKGBUILD
parent4f3a33cee5f9e4f3518f9448d54437b94e43c5c8 (diff)
downloadaur-python-azure-cli-acs.tar.gz
2.0.4 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fddf645ba071..f1f96bbf07b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=azure-cli-acs
pkgname=python-$_name
-pkgver=2.0.1
+pkgver=2.0.4
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools ACS Command Module"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure-cli-core' 'python-azure' 'python-scp' 'python-sshtunnel')
+depends=('python-azure-cli-command-modules-nspkg' 'python-azure-cli-core' 'python-azure' 'python-scp' 'python-sshtunnel')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('5376d7d42e390bd267050b2339cf859d')
+md5sums=('5df673ee1799b6b83247cd94e6c6156f')
build() {
cd "$_name-$pkgver"
@@ -21,4 +21,13 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
-} \ No newline at end of file
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
+}