diff options
author | Luis Martinez | 2023-03-30 21:55:46 -0500 |
---|---|---|
committer | Luis Martinez | 2023-03-30 21:55:46 -0500 |
commit | b9f8318db36813cd840c4a50cf4e2e43ba023bda (patch) | |
tree | 87e639548d3bfa80315f400b6cd605a27bef40d8 /PKGBUILD | |
parent | 364e4ce2187d6a11a2ca489646b74e57b3cb4f81 (diff) | |
download | aur-b9f8318db36813cd840c4a50cf4e2e43ba023bda.tar.gz |
packaging update
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 55 |
1 files changed, 33 insertions, 22 deletions
@@ -1,42 +1,53 @@ -# Maintainer: 0b100100 <0b100100 at protonmail dot ch> +# Maintainer: Luis Martinez <luis dot martinez at disroot dot org> +# Contributor: 0b100100 <0b100100 at protonmail dot ch> # Contributor: Lex Black <autumn-wind@web.de> # Contributor: Eric Toombs pkgname=python-binance-git -pkgver=1.0.15.r2.g217f1e2 -pkgrel=4 +_pkgname="${pkgname%-git}" +_pkg="${_pkgname#python-}" +pkgver=1.0.17.r1.g1b9dd48 +pkgrel=1 pkgdesc="An unofficial Python wrapper for the Binance exchange REST API" arch=('any') url="https://github.com/sammchardy/python-binance" license=('MIT') -depends=('python' 'python-aiohttp' 'python-dateparser' 'python-pytz' - 'python-requests' 'python-ujson' 'python-websockets') -makedepends=('git' 'python-setuptools') -checkdepends=('python-pytest' 'python-requests-mock') -provides=("${pkgname%-git}") -conflicts=("${pkgname%-git}") -source=("git+$url.git") -sha512sums=('SKIP') +depends=( + 'python-aiohttp' + 'python-pycryptodome' + 'python-dateparser' + 'python-pytz' + 'python-requests' + 'python-ujson' + 'python-websockets') +makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel') +# checkdepends=('python-pytest' 'python-requests-mock') +provides=("$_pkgname=${pkgver%.r*}") +conflicts=("$_pkgname") +source=("$_pkgname::git+$url") +sha256sums=('SKIP') pkgver() { - cd "${pkgname%-git}" - git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' + cd "$_pkgname" + git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' } build() { - cd "${pkgname%-git}" - python setup.py build + cd "$_pkgname" + python -m build --wheel --no-isolation } -check() { - cd "${pkgname%-git}" - pytest -} +# check() { +# cd "$_pkgname" +# pytest -x +# } package() { - cd "${pkgname%-git}" - python setup.py install --root="$pkgdir/" --optimize=1 --skip-build - install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/" + cd "$_pkgname" + python -m installer --destdir "$pkgdir" dist/*.whl + local _site="$(python -c 'import site; print(site.getsitepackages()[0])')" + install -dv "$pkgdir/usr/share/licenses/$pkgname/" + ln -sv "$_site/${_pkgname/-/_}-${pkgver%.r*}.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/" } # vim:set ts=2 sw=2 et: |