summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaximilian Weiss2024-03-19 17:40:14 -0700
committerMaximilian Weiss2024-03-19 17:40:14 -0700
commit99a663d5384c62205e93a9834ca7b40b27b06668 (patch)
tree830b8612c5ec62d3e331101faadaf21807b85838 /PKGBUILD
downloadaur-python-bitcoinx-git.tar.gz
Initial commit of new repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be2494cb8aa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Maximilian Weiss <$(echo "bWF4QG1heHdlaXNzLmlv" | base64 -d)>
+# Contributor: Neil Booth <$(echo "a3l1dXBpY2hhbkBnbWFpbC5jb20=" | base64 -d)>
+
+pkgname=python-bitcoinx-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Library of Bitcoin functions'
+arch=('any')
+url='https://github.com/kyuupichan/bitcoinX'
+license=('MIT')
+depends=('python-pycryptodomex' 'python-coincurve')
+provides=('python-bitcoinx-git' 'python-bitcoinx')
+conflicts=('python-bitcoinx-git' 'python-bitcoinx')
+source=('git+https://github.com/kyuupichan/bitcoinX')
+sha256sums=('SKIP')
+package() {
+ cd "$srcdir/bitcoinX/"
+ python setup.py install --root="$pkgdir/" --optimize=1 --prefix=/usr
+}