summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2021-05-26 14:38:23 +0000
committerBalló György2021-05-26 14:41:22 +0000
commitce792ab25f27511f91f29356f7857a917d25ce0f (patch)
tree87873f2eb3d441b5bf276712f42d9ca4e1e7a702 /PKGBUILD
downloadaur-python-cacheman.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54326db9dda2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=python-cacheman
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='Python interface for managing dependent caches'
+arch=('any')
+url='https://github.com/MSeal/py_cache_manager'
+license=('BSD')
+depends=('python-future' 'python-psutil' 'python-six')
+makedepends=('python-setuptools')
+source=("https://github.com/MSeal/py_cache_manager/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('bc266ebbcfa61adf1766c42b80ed998c124a202c7f4b91160eaf07990881182f')
+
+build() {
+ cd py_cache_manager-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd py_cache_manager-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}