summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpusi772023-05-07 15:47:09 +0200
committerpusi772023-05-07 15:47:09 +0200
commitc6c456dd2f9d05eba51eb7973f16ca8ef1b2500e (patch)
treee4c81f07cd1e4e75513923748677b186b1df55b3 /PKGBUILD
parent50985a965ccbc5fe3e0136230e28497b267611e4 (diff)
downloadaur-python-cipheydists.tar.gz
adopted and fixed broken package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2a330c9859a..20c6aec66643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
-# Maintainer: Roland Nagy <roliboy@protonmail.com>
-# Contributor: Hao Long <aur@esd.cc>
+# Maintainer: pusi77 <pusineriandrea+gmail+com>
pkgname=python-cipheydists
pkgver=0.3.35
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of sample distributions for use in Ciphey's frequency analysis"
arch=("any")
url="https://github.com/Ciphey/CipheyDists"
-license=("MIT")
+license=("The Unlicense")
depends=("python")
makedepends=(
+ "python-build"
+ "python-installer"
+ "python-wheel"
"python-setuptools"
- "python-poetry"
)
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/cipheydists/cipheydists-$pkgver.tar.gz")
-sha256sums=("3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88")
+sha256sums=('3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88')
build() {
cd "$srcdir/cipheydists-$pkgver"
- poetry build
-
- cd dist
- tar xf "cipheydists-$pkgver.tar.gz"
- cd "cipheydists-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/cipheydists-$pkgver/dist/cipheydists-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 "$srcdir/cipheydists-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "cipheydists-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}