summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Kudelin2023-10-24 15:20:05 +0300
committerAnton Kudelin2023-10-24 15:20:05 +0300
commite711d114ab615cd7bac075d3b6c3ef646e4788c7 (patch)
tree78f1eeba6d1168e6d2707fe97bee81823d136cf4 /PKGBUILD
parentf5fb149d51f5587df5018227678466c575c82168 (diff)
downloadaur-python-clickclick.tar.gz
adoption
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 27 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd4af171678c..0e98d9509030 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,41 @@
-# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
+# Maintainer: Anton Kudelin <kudelin at proton dot me>
+# Contributor: Filipe Laíns (FFY00) <lains@archlinux.org>
+_pyname=clickclick
pkgname=python-clickclick
pkgver=20.10.2
-pkgrel=5
+pkgrel=6
+arch=(any)
pkgdesc='Click command line utilities'
url='https://codeberg.org/hjacobs/python-clickclick'
-license=('Apache')
-arch=('any')
-depends=('python-click' 'python-yaml')
-makedepends=('python-setuptools' 'flake8')
-#checkdepends=('python-pytest-runner')
+license=(Apache)
+depends=(python-click python-yaml)
+makedepends=(python-setuptools python-build python-installer python-wheel flake8)
+checkdepends=(python-pytest)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha512sums=('d8954d231bff6945ac0e8350be05775a8a0b852dd0284e3446b3f9c8bc5861870ed1bc058e132c144fe8d543aee87d7a7a54894abdb4006664e5994c8cfb507f')
build() {
- cd $pkgname
-
- python setup.py build
+ cd "$srcdir/$pkgname"
+ python -m build \
+ --wheel \
+ --no-isolation \
+ --skip-dependency-check
}
-#check() {
-# cd $pkgname
-#
-# python setup.py test
-#}
+check() {
+ cd "$srcdir/$pkgname"
-package() {
- cd $pkgname
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ test-env/bin/python -m pytest -v -k 'not test_cli'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python -m installer \
+ --destdir="$pkgdir" \
+ --compile-bytecode=2 \
+ dist/*.whl
}