summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-09-06 13:57:47 -0500
committerLuis Martinez2021-09-06 13:57:47 -0500
commitb499f85fb10ecd2f088989e47681eea8e22e58a7 (patch)
tree5155c6758a088b6a170251a25c088ea3a2237e23 /PKGBUILD
parent404cb81a0f36cc65759d3929f7db443c1a3e4788 (diff)
downloadaur-python-cloudant.tar.gz
update to 2.15.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a993e5383cc9..838dd410135c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Riccardo Berto <riccardo at rcrdbrt dot com>
-pkgname='python-cloudant'
-_name='cloudant'
-pkgver=2.14.0
+pkgname=python-cloudant
+_name=cloudant
+pkgver=2.15.0
pkgrel=1
pkgdesc="Cloudant / CouchDB Client Library"
-url="https://github.com/cloudant/python-cloudant"
-depends=('python-requests')
-makedepends=('python-setuptools')
license=('Apache')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('afb00331a6c8593ba849294e907ebf188ee90548b1b96d0ee98669ffeb5df320')
+url="https://github.com/cloudant/python-cloudant"
+depends=('python-requests>=2.7.0')
+makedepends=('python-setuptools')
+install=cloudant.install
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('ac2f5136e4f8fba5c838643603b5272c5cfb6ed2240edb580fe3c2c5a5fcda63')
build() {
- cd "$_name-$pkgver"
- python setup.py build
+ cd "$_name-$pkgver"
+ python setup.py build
}
package() {
- cd "$_name-$pkgver"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ cd "$_name-$pkgver"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}