summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorian Coltof2020-05-27 17:10:48 +0200
committerLorian Coltof2020-05-27 17:10:48 +0200
commit38c29b27bd029c35a54f0b66a026ea8278759ebd (patch)
tree27b81dd7d414c327b4f4b1b65fa8c2fb809d19fe /PKGBUILD
downloadaur-python-codegrade-fs.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dd62992529c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lorian Coltof <loriancoltof@gmail.com>
+
+pkgname=python-codegrade-fs
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Python module for the CodeGrade filesystem"
+arch=('x86_64')
+license=('AGPL3')
+
+url="https://codegrade.com"
+depends=('python' 'python-fusepy' 'python-requests')
+makedepends=('python-setuptools' 'git')
+source=("$pkgname-$pkgver::git+https://github.com/CodeGra-de/CodeGra.fs.git#commit=50d99b53fe6043382ed514377394f73d6335191f")
+sha256sums=('SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+
+ python setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}