summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A.2023-12-27 15:56:40 +0100
committerPhilipp A.2023-12-27 15:56:40 +0100
commitf88ecb6932cf7901e37c0409b101349d1c4d88b7 (patch)
tree1addc6094fe500531105cb617dc3816142058049 /PKGBUILD
parenteee26bf865060c3e6311679f7b6db769a8d294bf (diff)
downloadaur-python-connection_pool.tar.gz
build system update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0da5b12370f..ffa1f252ece7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,22 @@
_name=connection_pool
pkgname=python-$_name
pkgver=0.0.3
-pkgrel=1
+pkgrel=2
pkgdesc='Thread-safe connection pool for Python'
arch=(any)
url='https://github.com/zhouyl/ConnectionPool'
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('bf429e7aef65921c69b4ed48f3d48d3eac1383b05d2df91884705842d974d0dc')
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}