summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-09-07 23:09:42 -0500
committerLuis Martinez2022-09-07 23:09:42 -0500
commitcc79813b621963d99c4cd2753c9313a0c66b8c39 (patch)
tree28500ac5e8f679c8bd8c6ea513b75c5e2173124a /PKGBUILD
parent2665758e3a83949c98c4b6710232354d4ca56abd (diff)
downloadaur-python-coveralls.tar.gz
update to 3.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cd81c31ffb6..f59a422d4c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,37 @@
# Contributor: GI_Jack <GI_Jack@hackermail.com>
pkgname=python-coveralls
-pkgver=3.3.0
-pkgrel=3
+_pkg="${pkgname#python-}"
+pkgver=3.3.1
+pkgrel=1
+_commit=c35bf51
pkgdesc="Python integration with coveralls.io"
url="https://github.com/thekevjames/coveralls-python"
arch=('any')
license=('MIT')
depends=('python-coverage' 'python-docopt' 'python-requests')
optdepends=('python-yaml')
-makedepends=('python-setuptools')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
checkdepends=('git' 'python-mock' 'python-pytest' 'python-responses')
changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('466ade75b818f8fb240a3049de0d3896a7d1efec878ead7b4d878935a7af386a')
+source=("$pkgname::git+$url#commit=$_commit?signed")
+sha256sums=('SKIP')
+validpgpkeys=('ED35BBC75D8B80DA1949AABDB2B0BD2FE4EE84C5') ## Kevin James
build() {
- cd "coveralls-python-$pkgver"
- python setup.py build
+ cd "$pkgname"
+ python -m build --wheel --no-isolation
}
check() {
- cd "coveralls-python-$pkgver"
+ cd "$pkgname"
pytest -x
}
package() {
- export PYTHONHASHSEED=0
- cd "coveralls-python-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+ cd "$pkgname"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "$_site/$_pkg-$pkgver.dist-info/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/"
}