summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOlivier Le Moal2020-01-04 17:11:58 +0100
committerOlivier Le Moal2020-01-04 17:11:58 +0100
commita4f9b9526aa50ddfd6517f9ce176c166f09f31a4 (patch)
tree572aec085e248d858fb2b61098483cecada17b00 /PKGBUILD
downloadaur-python-cryptomobile.tar.gz
first PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1231bf3c7f56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Olivier Le Moal <mail@olivierlemoal.fr>
+pkgname='python-cryptomobile'
+pkgver=r26.c17b23a
+pkgrel=1
+pkgdesc="This toolkit implements python wrappers around 3G and LTE encryption and integrity protection algorithms, COMP128, Milenage and TUAK authentication algorithms."
+arch=(any)
+url="https://github.com/P1sec/CryptoMobile"
+license=('GPL')
+makedepends=('git')
+depends=('python')
+source=('pycrate::git+https://github.com/P1sec/CryptoMobile#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd pycrate
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd pycrate
+ python setup.py install --root="$pkgdir" --optimize=1
+}