summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:14:41 -0400
committerKyle Keen2015-06-13 00:14:41 -0400
commita96563ec5ef587187cedc363707213964d2abb99 (patch)
tree74d58833314a24f5410b7bbb59a9efdec2228a27 /PKGBUILD
downloadaur-python-cs1graphics.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff44019376f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=python-cs1graphics
+pkgver=1.2
+pkgrel=2
+pkgdesc="Simple python2/python3 graphics library."
+arch=('any')
+url="http://www.cs1graphics.org/"
+license=('GPL3')
+depends=('tk')
+optdepends=('python: for python3 support'
+ 'python2: for python2 support')
+source=(http://www.cs1graphics.org/download/v$pkgver/$pkgname.py)
+md5sums=('2abf99242b7fd77990ad5a80afad6ac1')
+
+package() {
+ cd "$srcdir"
+ # link together instead? use a real python setup?
+ install -Dm644 cs1graphics.py "$pkgdir/usr/lib/python2.7/site-packages/$pkgname/__init__.py"
+ install -Dm644 cs1graphics.py "$pkgdir/usr/lib/python3.2/site-packages/$pkgname/__init__.py"
+}