summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2023-07-05 23:37:52 +0200
committerNarrat2023-07-05 23:37:52 +0200
commit3fb257045021b6d810c1c70cdd9574f7eddef585 (patch)
treeea7768d92b78476972f804dc9095ed3dc270860b /PKGBUILD
downloadaur-python-dj-config-url.tar.gz
python-dj-config-url: initial commit (and the last)
Needed for papermerge-core
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b75ab69ff7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Lex Black <autumn-wind@web.de>
+
+_base=dj-config-url
+pkgname=python-${_base}
+pkgver=0.1.1
+pkgrel=1
+arch=(any)
+pkgdesc="12factor inspired URLs to configure your Django Application (deprecated)"
+url="https://github.com/julianwachholz/${_base}"
+license=(BSD)
+depends=(python)
+makedepends=(python-setuptools)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz)
+sha512sums=('a62d42eca302de5d4b762e72641e5e9c0548f104eca46a687a1dcb940d6dc5e6cd0d442d0c6ab57a0e43afdf5d6110ef28d3bcfaed4437a93c6cfdf57eb55477')
+
+build() {
+ cd "${_base}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_base}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE.txt
+}