summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoffrey2024-05-09 08:49:04 +0200
committerJoffrey2024-05-09 08:49:04 +0200
commit37528406b09c86a9c46e6632ba641a76bf72cba7 (patch)
treed8d458e28d071c00baf534cf5f922fc883012ec9 /PKGBUILD
parent29cb86a6b239f9fcf5f40d6e2ee24946e05f810f (diff)
downloadaur-python-django-simple-captcha.tar.gz
Rebuild with build module
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d68726d9721..2b119236f49a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='python-django-simple-captcha'
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='Django application to add captcha images to any Django form'
arch=('any')
url='https://github.com/mbi/django-simple-captcha'
@@ -13,12 +13,22 @@ depends=(
'python-pillow'
'python-django-ranged-response'
)
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('0b798d7572df98330c9975cd343a229b787d30bf9fdb8b852b307b5073af0ed0')
+build() {
+ cd "$srcdir/django-simple-captcha-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "$srcdir/django-simple-captcha-$pkgver"
install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python './setup.py' install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}