summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkikislater2025-03-18 23:06:57 +0400
committerkikislater2025-03-18 23:06:57 +0400
commit0697b0df9e3b1f94c25d2321139501aa44eff59d (patch)
tree426c2209f4ee523f94a2177a55018a36e19ff2ef /PKGBUILD
parent4809086d41f1e463a5dd133613aa9e7eeb04e086 (diff)
downloadaur-python-earcut.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86fa56617047..bcf4a16df7e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,24 @@ pkgver=1.15
pkgrel=1
pkgdesc="A pure Python port of the earcut JS triangulation library"
arch=('any')
-url="https://pypi.org/project/$_pkgname/"
+url="https://github.com/vojtatom/${_pkgname}.py"
license=('ISC')
depends=('python' 'python-pip')
makedepends=('python-setuptools')
-#source=()
-#sha256sums=()
+source=("${url}/archive/refs/heads/master.tar.gz")
+sha256sums=('89173d1870b9eaca4dabdc6e51d3ce72e7a038c56ae94598c666a6d59b4efc58')
+
+build() {
+ cd "${srcdir}/${_pkgname}.py-master"
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
package() {
- pip install --root="$pkgdir" --prefix=/usr --no-warn-script-location $_pkgname
+ cd "${srcdir}/${_pkgname}.py-master"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ # rm -r "${pkgdir}${site_packages}/${_base}"/tests/
+ # mv "${pkgdir}/usr/etc" "${pkgdir}/etc"
}
+