summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212024-05-16 22:50:29 +0200
committera8212024-05-16 22:50:29 +0200
commit78330c1337465b62b04988161e2be489a7cd78e9 (patch)
tree0aab19e1825945c13b285a05b2c7446d364584fc /PKGBUILD
parent678cf546cdaaa5dd38afe5be90bdc9876447eabf (diff)
downloadaur-python-editdistance.tar.gz
Version 0.8.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed99ea905b6e..85a65cacde7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Maintainer: a821 at mail de
+# Contributor: Felix Yan <felixonmars@archlinux.org>
pkgname=python-editdistance
-pkgver=0.6.2
-pkgrel=3
+pkgver=0.8.1
+pkgrel=1
pkgdesc="Fast implementation of the edit distance(Levenshtein distance)"
arch=('x86_64')
license=('MIT')
url="https://github.com/aflc/editdistance"
depends=('python')
-makedepends=('python-setuptools' 'cython')
-checkdepends=('python-nose')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/aflc/editdistance/archive/v$pkgver.tar.gz"
- LICENSE)
-sha512sums=('8d44d310351c688180fb783d87922a954427618793fa6d15e1d231b4cf0efafd9ecfdfbbcf4453021ad189870d01eb72ea3ba4de57f333ffbb157bb4b8529cd2'
- '590232c1e7fa5aaaaa77573c4ea23533522177ca0ac07a0ce7f00e446d47467df2e19936ecb5e057fddc664d1daca39e2217cb5f6e3192ef5edf49b1f73e0f10')
+makedepends=('cython'
+ 'python-build'
+ 'python-installer'
+ 'python-pdm-backend'
+ 'python-setuptools'
+ 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/aflc/editdistance/archive/v$pkgver.tar.gz")
+sha512sums=('2e8c01d6414c82ecb06f03c756938e099be2b36134705ebe302a38fea1f914a43c698c620bc6be0e9cc628b71c7c8bf8d069ea38e186945bd717e366108ddc3c')
build() {
cd editdistance-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd editdistance-$pkgver
- python setup.py nosetests
+ PYTHONPATH=.pdm-build python -m unittest discover test
}
package() {
cd editdistance-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
- install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}