summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-12 19:38:06 -0600
committerLuis Martinez2022-03-12 19:38:06 -0600
commit3f54335c4e077f62a0ead5d967791e655704dd73 (patch)
treee0576b835235fdda4f0575e693c284c8b33a2cae /PKGBUILD
parent62fe2bea78a3511bc98f0621df2c04dd076b9337 (diff)
downloadaur-python-eliot.tar.gz
update packaging to new python standards
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe3750537c57..4afcd87ad9cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,18 @@
pkgname=python-eliot
pkgver=1.14.0
-pkgrel=2
+pkgrel=3
pkgdesc='Logging that tells you why it happened'
arch=('any')
url='https://github.com/itamarst/eliot'
license=('Apache')
depends=('python-six' 'python-zope-interface' 'python-pyrsistent' 'python-boltons')
-makedepends=('python-setuptools' 'python-sphinx')
+makedepends=(
+ 'python-setuptools'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-sphinx')
checkdepends=('python-pytest' 'python-hypothesis' 'python-testtools')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/e/eliot/eliot-$pkgver.tar.gz")
sha256sums=('c2f099a3e8d5ecfc22745766e7cc664a48db64b6b89d986dff270491d8683149')
@@ -22,19 +27,19 @@ prepare() {
build() {
cd "eliot-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
( cd docs; make man )
}
check() {
cd "eliot-$pkgver"
## test_prettyprint requires python-eliot installed at runtime; exclude it
- pytest -x --ignore eliot/tests/test_prettyprint.py
+ pytest -x --ignore eliot/tests/test_prettyprint.py --disable-warnings
}
package(){
export PYTHONHASHSEED=0
cd "eliot-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 docs/build/man/eliot.1 -t "$pkgdir/usr/share/man/man1/"
}