summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2024-04-17 12:48:14 +0800
committerYour Name2024-04-17 12:48:14 +0800
commitd254585ba5921ea1f044eca06555e499a752ebb2 (patch)
tree532a398cd9bdd39b369b1d1a1aa988f78fb3402f /PKGBUILD
parentb24629ca01ac9f276d0e711d333af81efb443e08 (diff)
downloadaur-python-fast-histogram.tar.gz
Update to version 0.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fa85a775c51..bc39fe2dfbcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-fast-histogram
_pyname=fast_histogram
-pkgver=0.13
+pkgver=0.14
pkgrel=1
pkgdesc="Fast 1D and 2D histogram functions in Python"
arch=('i686' 'x86_64')
@@ -17,7 +17,7 @@ makedepends=('python-setuptools-scm'
checkdepends=('python-pytest'
'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('da27a74b5ad7ebaf04b4a855c2ade39a9d41fbdb6ee7f07cba159422045c7af2')
+sha256sums=('390973b98af22bda85c29dcf6f008ba0d626321e9bd3f5a9d7a43e5690ea69ea')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -31,7 +31,7 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count \
+ pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count \
# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_1d_compare_with_numpy \
# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_2d_compare_with_numpy \
# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_dd_compare_with_numpy #|| warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count