summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2022-06-06 22:45:02 -0400
committerGuillaume Horel2022-06-06 22:45:02 -0400
commit0dd198f72776faa4b7f580d6b26f9c7793ba43b5 (patch)
treeedfb0e89e08f24b46689318cedbdcb0f9ed8c3ba /PKGBUILD
parent6d2209c1dfec42151c53fd7db264ade2875a1643 (diff)
downloadaur-python-fastparquet.tar.gz
bump to 0.8.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92b530203d09..66e0bd5115d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,31 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-fastparquet'
_module='fastparquet'
-pkgver='0.4.0'
+pkgver='0.8.1'
pkgrel=1
pkgdesc="A python implementation of the parquet format."
url="https://github.com/dask/fastparquet"
-checkdepends=('python-pytest'
- 'python-snappy'
- 'python-lz4')
-depends=('python' 'python-numba'
- 'python-numpy'
- 'python-thrift')
+checkdepends=('python-pytest')
+depends=(python python-cramjam python-fsspec)
makedepends=('cython' 'python-setuptools')
-optdepends=('python-snappy'
- 'python-lz4'
- 'python-lzo'
- 'python-brotli'
- 'python-zstandard')
+optdepends=('python-s3fs')
license=('Apache')
arch=('x86_64')
source=("https://github.com/dask/fastparquet/archive/$pkgver.tar.gz")
-sha256sums=('34c0a94e36710cc7615770661888d9c610da3925cd2bd6164bc6d5682530814c')
+sha256sums=('591e20b128da87e369aa23178a29f2aaff4e4e69feab845be7ea456b3213fc96')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py build
}
check() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py build_ext --inplace
pytest
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}