summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTrumeet2021-03-24 16:50:18 -0700
committerTrumeet2021-03-24 16:50:18 -0700
commit0687918bc5a931383848706623688f6a604f18de (patch)
tree6efacc00435e2b523fb2a604f26285b9c566e0e5 /PKGBUILD
downloadaur-python-favicons.tar.gz
First Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3192d9329c1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Yuuta Liang <yuuta@yuuta.moe>
+pkgname=python-favicons
+pkgver=0.0.9
+pkgrel=1
+epoch=
+pkgdesc="Favicon generator for Python 3 with strongly typed sync & async APIs, CLI, & HTML generation"
+arch=(any)
+url="https://github.com/checktheroads/favicons"
+license=('BSD')
+groups=()
+depends=('python' 'python-pillow' 'python-rich' 'python-svglib' 'python-typer')
+makedepends=('python-setuptools')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+_name=${pkgname#python-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+noextract=()
+md5sums=('19091796d3c4a339be590ed87875ee4c')
+validpgpkeys=()
+
+prepare() {
+ cd "$_name-$pkgver"
+}
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$_name-$pkgver"
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ mkdir -p $pkgdir/usr/share/licenses/${pkgname}/
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/
+}