summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-25 22:15:08 -0500
committerCarlos Aznarán2024-04-25 22:15:08 -0500
commitcfebe6b5f83f75d1eca1b9bdb39e49fba8e7d438 (patch)
tree7c1114771805340d4b15b6a75daca2f127fb1bfe /PKGBUILD
parent94ad0e16cbe8c3f0137f41df2263e3c99cb0db99 (diff)
downloadaur-python-fenics-dolfinx.tar.gz
Bump version to 0.8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ffdd2e2acf2..3af1a39d1236 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,24 @@
_base=dolfinx
pkgname=python-fenics-${_base}
pkgdesc="Next generation FEniCS problem solving environment (python interface)"
-pkgver=0.7.3
+pkgver=0.8.0
pkgrel=1
arch=(x86_64)
url="https://github.com/FEniCS/${_base}"
license=(LGPL-3.0-or-later GPL-3.0-or-later)
depends=(dolfinx python-mpi4py)
-makedepends=(python-build python-installer python-setuptools python-wheel pybind11 cmake)
-checkdepends=(python-pytest python-cppimport python-scipy eigen python-matplotlib python-numba)
+makedepends=(python-build python-installer python-scikit-build-core python-wheel nanobind)
+checkdepends=(python-pytest python-sympy python-scipy python-matplotlib python-numba)
optdepends=('python-pyvista: for plotting'
'python-numba: for jit support'
'slepc: for eigenvalue solver support'
'gmsh: for extract data from Gmsh models')
-source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
-timer_fix.patch::${url}/pull/2966.patch)
-sha512sums=('2181247edef9f4e3f7b181dc6fc755402a2b9dcf871ed0bcfda53b8bc36a98678cab3306918c16b67e13f04ffc1f161f0c9c290241a4222013b47eac4c8c261c'
- '63674969f4af1f76725464b1b7f8ec2ff1805abd06429c41abf553ebfb997f95712104c5f81f924a8aa6e4c30723bfb5a9e296123a87086fefc5f6a1cf2f5c9c')
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('2f3ee72733f058bfa77548a3f5955fd43ad24a1d5643a26cf513b263c9ae089d73b7062bc8ebc9986baebc26804f9763a7ef8f957ff1b532605ad96310862d35')
prepare() {
- cd ${_base}-${pkgver}
- patch -p1 -i ../timer_fix.patch
+ sed -i 's/^wheel.license-files/#wheel.license-files/' ${_base}-${pkgver}/python/pyproject.toml
+ sed -i 's/^license/#license/' ${_base}-${pkgver}/python/pyproject.toml
}
build() {
@@ -31,14 +29,15 @@ build() {
}
check() {
+ cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
- test-env/bin/python -m installer ${_base}-${pkgver}/python/dist/*.whl
- MPLBACKEND=Agg test-env/bin/python -m pytest ${_base}-${pkgver}/python/test/unit \
- -k 'not context_manager_anonymous and not nonmatching_mesh_interpolation and not nonmatching_mesh_single_cell_overlap_interpolation'
- MPLBACKEND=Agg test-env/bin/python -m pytest ${_base}-${pkgver}/python/demo/test.py
+ test-env/bin/python -m installer python/dist/*.whl
+ MPLBACKEND=Agg test-env/bin/python -m pytest python/test/unit
+ MPLBACKEND=Agg test-env/bin/python -m pytest python/demo/test.py
}
package() {
- cd ${_base}-${pkgver}/python
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" python/dist/*.whl
+ install -Dm 644 COPYING* -t "${pkgdir}/usr/share/licenses/${pkgname}"
}