summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicholas Yim2017-08-01 14:21:00 +0800
committerNicholas Yim2017-08-01 14:21:00 +0800
commit12374e38292692bef567326a204835e12867b9a1 (patch)
tree7f9ecf451d5c9cf38703aa35a1a4c5389c61fce7 /PKGBUILD
downloadaur-python-flask-jsonrpc.tar.gz
init commit python-flask-jsonrpc-0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93036bf12d10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nicholas Yam <nickyim05@gmail.com>
+
+pkgname=python-flask-jsonrpc
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Adds JSONRPC support to Flask."
+arch=('any')
+depends=('python-flask')
+makedepends=('python-setuptools')
+url="https://github.com/cenobites/flask-jsonrpc"
+license=('BSD 3-clause')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/cb/1f/e6d66e8498609ba04bac76155b2ea884df95531e93501bf4ef009d40a83c/Flask-JSONRPC-0.3.1.tar.gz)
+md5sums=('5c0592f53b2f18e34d5be435acee8842')
+sha256sums=('4d0cc9c20874093306af91f5a48009fb8659a041428dcdb11703598ffbbc97d0')
+
+build() {
+ cd "$srcdir/Flask-JSONRPC-$pkgver"
+
+ msg2 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/Flask-JSONRPC-$pkgver"
+
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}