summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2020-01-10 23:47:11 +0000
committerAntonio Rojas2020-01-10 23:47:11 +0000
commit90337de81b656f218750e1f13a0474f12536c059 (patch)
tree6457775970194bb4e508ab270a39814f2ad1e8c6 /PKGBUILD
downloadaur-python-flask-oldsessions.tar.gz
Dropped from repos
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..708fc3595b83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname='python-flask-oldsessions'
+pkgver=0.10
+pkgrel=5
+pkgdesc='Provides a session class that works like the one in Flask before 0.10'
+url='https://github.com/mitsuhiko/flask-oldsessions'
+arch=('any')
+license=('custom:BSD')
+depends=('python-flask')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mitsuhiko/flask-oldsessions/archive/$pkgver.tar.gz")
+sha256sums=('056e16cbe89187dc5c5fff019aa20c60daec32be2334848f4b813ce51e6701fb')
+
+prepare() {
+ cp -r "flask-oldsessions-$pkgver" "python-flask-oldsessions-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+