summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2024-06-30 18:29:31 -0500
committerHurricanePootis2024-06-30 18:29:31 -0500
commit4529c9fb61f664e6f7f178950378bb40968d673b (patch)
treed8cac4922baf82d1fe896ab50f82cbe1e47f55de /PKGBUILD
downloadaur-python-flexparser.tar.gz
Initial commit 0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22fecd42b6aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+pkgname=python-flexparser
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A parser by hgrecco"
+arch=(any)
+url="https://github.com/hgrecco/flexparser"
+license=('BSD-3-Clause')
+depends=('python' 'python-typing_extensions' 'python-pytest7')
+makedepends=('python-wheel' 'python-build' 'python-installer' 'python-setuptools' 'python-setuptools-scm' 'python-ruff'
+ 'git')
+checkdepends=('python-pytest-mpl' 'python-pytest-cov' 'python-pytest-subtests')
+source=("$pkgname::git+$url.git#tag=${pkgver}")
+sha256sums=('e3de6665dc91aba4d9657b86824f884a1069ae7e6c00796b2c8a6f09806b6029')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "$srcdir/$pkgname"
+ pytest
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}