summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2022-03-21 17:39:10 +0700
committerAchmad Fathoni2022-03-21 17:39:10 +0700
commit09883077871af04331e3e800813c606b3fdde56c (patch)
tree0aa9d24a6563ba9b39e31fadde77fbdaaded0aa0 /PKGBUILD
downloadaur-python-fred.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c7e2ff183be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-fred
+_pkgname=${pkgname:7}
+pkgver=3.1
+pkgrel=1
+pkgdesc="St. Louis Federal Reserve FRED API"
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('MIT')
+makedepends=(python-build python-installer python-wheel)
+depends=(python python-requests)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('f31327d648917694b8d15d66ca4e82a082dbb88ca027bdcc9d56738cbc836a6a')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}