summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNils Werner2023-10-24 12:28:19 +0200
committerNils Werner2023-10-24 12:28:19 +0200
commit1d7f019e724c30a774eafb0c1fe7daccfac7bbca (patch)
tree0f7b86d27e989589032e1fa86f5427454ae14c42 /PKGBUILD
parentcf7ab7f8bd28b20a143b5fdad74645db492806d1 (diff)
downloadaur-python-fritzconnection-git.tar.gz
Change installer method, add python-segno optional dependency, and bump version
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e85beb9ca33..ec33bac81336 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=python-fritzconnection-git
-pkgver=1.2.1.r17.g29ececd
+pkgver=1.9.1.r282.g1e200b1
pkgrel=1
pkgdesc='Python-Tool to communicate with the AVM Fritz!Box.'
license=('MIT')
@@ -13,7 +13,13 @@ depends=(
'python-requests'
)
makedepends=(
+ 'python-build'
+ 'python-installer'
'python-setuptools'
+ 'python-wheel'
+)
+optdepends=(
+ 'python-segno: QR code support'
)
source=("git+https://github.com/kbr/fritzconnection.git")
sha512sums=('SKIP')
@@ -25,10 +31,10 @@ pkgver() {
build() {
cd fritzconnection
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd fritzconnection
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}