summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron DeVore2015-09-05 13:19:43 -0700
committerAaron DeVore2015-09-05 13:19:43 -0700
commiteb1c1839cb3d3c355975b777d4dba8973ca95e62 (patch)
tree0d0179db6a69b7e2d988d3a380c35c761ee93603 /PKGBUILD
parent466f831c9fe490d6d001bf9a4f49a706f877c0dd (diff)
downloadaur-python-fudge-docs.tar.gz
Version bump to 1.1.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b38183fe0b7..a2d45352781a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: tocer <tocer.deng@gmail.com>
pkgname=python-fudge-docs
-pkgver=1.0.3
+pkgver=1.1.0
pkgrel=1
pkgdesc="Use fake objects (mocks, stubs, etc) to test real ones"
arch=(any)
@@ -11,19 +11,22 @@ license=(MIT)
depends=()
makedepends=('python2-sphinx')
source=(http://pypi.python.org/packages/source/f/fudge/fudge-$pkgver.tar.gz)
-md5sums=('ee0797e0a28732e630938da16137240a')
+md5sums=('2e10ff35c998bf4bce8c5a986c5181bd')
build() {
+ cd "$srcdir/fudge-$pkgver/docs"
+ make html SPHINXBUILD=sphinx-build2
+}
+
+package() {
cd "$srcdir/fudge-$pkgver"
install -Dm644 LICENSE.txt \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
- cd docs
# python-sphinx (Sphinx for Python 3) tries to import Fudge before
# running 2to3 fixers. Instead, use python2-sphinx to correctly
# import the unfixed code.
- make html SPHINXBUILD=sphinx-build2
mkdir -p "$pkgdir/usr/share/doc/python-fudge/"
- cp -a _build/html "$pkgdir/usr/share/doc/python-fudge/"
+ cp -a docs/_build/html "$pkgdir/usr/share/doc/python-fudge/"
}