summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorchen-chao2019-01-06 21:55:03 +0800
committerchen-chao2019-01-06 21:55:03 +0800
commit0be130bae0ab7ce17ee511df5618809cc26412e9 (patch)
tree0aaf02117616af24e97702114b7d0c433297fa56 /PKGBUILD
parentd5ca1a6f62d265db5710affb28fb71f922c4c1db (diff)
downloadaur-python-fuocore.tar.gz
updated to version 2.3 from pypi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86e8d07122b7..7c408b77feb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
pkgbase=('python-fuocore')
pkgname=('python-fuocore')
_module='fuocore'
-pkgver='2.0.2'
+pkgver='2.3'
pkgrel=1
pkgdesc="feeluown core"
url="https://github.com/cosven/feeluown-core"
depends=('python' 'mpv' 'python-beautifulsoup4' 'python-marshmallow' 'python-crypto' 'python-requests' 'python-mutagen' 'python-fuzzywuzzy')
-makedepends=('git' 'python-setuptools')
+makedepends=('python-setuptools')
provides=("${pkgname}=${pkgver}")
license=('MIT')
arch=('any')
-source=("${pkgname}"::'git://github.com/cosven/feeluown-core.git')
-md5sums=('SKIP')
+source=("${pkgname}"::'https://files.pythonhosted.org/packages/59/61/4ecaf91c6075d468f0343747565489bb65d3ef0238ec5176381121ae5ab4/fuocore-2.3.tar.gz')
+sha256sums=('ad0f0d6f8c96fe0a46d2fa658515f50613e8daa8cce56eece58d702d1e9e4d51')
+dirname="fuocore-${pkgver}"
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${dirname}"
python setup.py build
}
package() {
depends+=()
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${dirname}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}