summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Saleeba2021-07-01 22:20:54 -0600
committerTom Saleeba2021-07-01 22:20:54 -0600
commit9ef4ea965ec57f4afc913500cf17424d50146bcc (patch)
tree9746aeb6a5a2f6017adc212acba6b9b7240b9ba5 /PKGBUILD
parenteafd1892781d15b2b7e5345f8cd8cddd5d5aa910 (diff)
downloadaur-python-gattlib.tar.gz
feat: bump to version 0.20201113, which no longer requires patching
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10c44ae01a46..4f55aaf3e371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Maintainer: rains31@gmail.com
pkgname=python-gattlib
-pkgver=0.20150805
-pkgrel=3
+pkgver=0.20201113
+pkgrel=1
pkgdesc='This is a Python library to use the GATT Protocol for Bluetooth LE devices. It is a wrapper around the implementation used by gatttool in bluez package. It does not call other binaries to do its job :)'
arch=(any)
-url="https://bitbucket.org/OscarAcena/pygattlib"
+url="https://github.com/OscarAcena/pygattlib"
license=('Apache')
-depends=('python' 'boost' 'bluez-libs')
+depends=('python' 'boost' 'bluez-libs' 'glib2')
makedepends=('python-setuptools')
source=(
- "https://pypi.python.org/packages/be/2f/5b1aecec551b42b59d8b399ad444b5672972efb590ca83d784dbe616a3e1/gattlib-0.20150805.tar.gz#md5=f620eca190bb7acd67c7aafecaedb6c2"
- "gattlib.patch"
+ "https://files.pythonhosted.org/packages/fe/8d/72d539dd6be2d9677864a1604b8db80696c2d5f018cf8093bf442311162f/gattlib-0.20201113.tar.gz"
)
md5sums=(
- "f620eca190bb7acd67c7aafecaedb6c2"
- "e18b425b78862d42d4896ea1f4b54252"
+ "433581aba2b9d3b621094fb62d20dfd5"
)
build() {
cd "${srcdir}/gattlib-${pkgver}"
- patch -p1 -i ../gattlib.patch
+ python3 setup.py build
}
package() {