summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClayton Craft2018-05-30 16:10:28 -0700
committerClayton Craft2018-05-30 16:10:28 -0700
commitddcdf549a4e55d4eb5b4dc874ac83c0e90f8fe83 (patch)
tree41e799a050f82348ae4c13f435c13d3000e34f7d /PKGBUILD
parenta8f985c0a3cd59a0140aef1b655d453a18dc5904 (diff)
downloadaur-python-geohash.tar.gz
Fix issue with Python >= 3.5 and change maintainership
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c61207263a2..74858afd8eae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
-# Maintainer: Your Name <youremail@domain.com>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=python-geohash
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="Fast, accurate python geohashing library"
arch=('any')
url="https://github.com/hkwi/python-geohash"
license=('APACHE')
-groups=()
depends=('python' 'python-docutils')
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
options=(!emptydirs)
-install=
-source=('https://pypi.python.org/packages/74/84/fa80c5e92854c7456b591f6e797c5be18315994afd3ef16a58694e1b5eb1/Geohash-1.0.tar.gz')
-md5sums=('a7c4e57874061fae1e30dd8aa8b9b390')
+install=${pkgname}.install
+source=('https://pypi.python.org/packages/74/84/fa80c5e92854c7456b591f6e797c5be18315994afd3ef16a58694e1b5eb1/Geohash-1.0.tar.gz'
+ '0001-fix-python-3.5.patch')
+#source=()
+#md5sums=('a7c4e57874061fae1e30dd8aa8b9b390')
+sha256sums=('2dd849ebaa0bc7ee565444df4fc57ae33daa89afa24b43617556560a04b71900'
+ '0acc9bd46bd11f808b97d0f6a07644204d8127ca146ea2ed8b3578d71142c39b')
+
+build() {
+ cd "${srcdir}/Geohash-${pkgver}"
+
+ # https://github.com/vinsci/geohash/issues/4
+ patch -p1 < "${srcdir}/0001-fix-python-3.5.patch"
+}
package() {
cd "$srcdir/Geohash-$pkgver"
- /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1
+ /usr/bin/python setup.py install --root="${pkgdir}/" --optimize=1
}
# vim:set ts=2 sw=2 et: