summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArkadiy Illarionov2023-12-05 00:27:46 +0300
committerArkadiy Illarionov2023-12-05 00:28:38 +0300
commitdcd59bb850c4f768b992b9ba041f72c76c5e4c6f (patch)
tree208340b424d4fedaf4b8500c66e221b8a7325dd9 /PKGBUILD
downloadaur-python-get-video-properties.tar.gz
Add python-get-video-properties
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7ee2a05a94e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=python-get-video-properties
+_name=${pkgname#python-}
+_name2=${_name//-/_}
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Get video properties"
+url="https://github.com/mvasilkov/python-get-video-properties"
+depends=(
+ ffmpeg
+ python
+)
+makedepends=(
+ python-installer
+)
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name2}-$pkgver-py3-none-any.whl")
+sha256sums=('04d4f478a5211917e2a7e87ddfcb1c17734cddf8374494c3993bf825b7ad4192')
+
+package() {
+ python -m installer --destdir="$pkgdir" "${_name2}-$pkgver-py3-none-any.whl"
+
+ local site_packages
+ site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "$pkgdir/$site_packages/videoprops/binary_dependencies"
+
+ install -Dm644 "${_name2}-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}