summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2024-05-01 19:18:12 +0800
committertaotieren2024-05-01 19:18:12 +0800
commitec91459b9df37400a597275fe2adca14770e3f01 (patch)
tree90b6280bbc8accb6c2c41b7fdce16632dee42e8f /PKGBUILD
parent63d8bd6b6e6fdb00c37436c172f9837e720f091e (diff)
downloadaur-python-glyphslib-git.tar.gz
update python-glyphslib-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1172949e050..b30d04f80c93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,17 +13,18 @@ _pydeps=(fonttools
ufolib2
unicodedata2) # for fonttools[unicode]
depends=(python
- "${_pydeps[@]/#/python-}")
+ xmldiff
+ "${_pydeps[@]/#/python-}")
makedepends=(python-{build,installer,wheel}
- python-defcon
- python-setuptools-scm
- git)
+ python-defcon
+ python-setuptools-scm
+ git)
_pycheckdeps=(lxml # for fonttools[lxml]
- pytest
- ufo2ft
- ufonormalizer
- xmldiff)
-checkdepends=("${_pycheckdeps[@]/#/python-}")
+ pytest
+ ufo2ft
+ ufonormalizer)
+checkdepends=("${_pycheckdeps[@]/#/python-}"
+ xmldiff)
optdepends=(python-defcon
python-ufonormalizer)
provides=("${pkgname%-git}")
@@ -36,6 +37,11 @@ pkgver() {
git describe --long --tags | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
build() {
cd "$pkgname"
python -m build -wn