summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2019-12-11 09:27:59 -0500
committerSolomon Choina2019-12-11 09:27:59 -0500
commitc8e7685200d11ca3dc6daf4b4f0b32335eb8b4c3 (patch)
treed6afdff0245ce9c49a9bdfa77aa416de2418caf4 /PKGBUILD
parent152004a16f3f5564a250381885c0463686edc905 (diff)
downloadaur-python-gmusicapi-git.tar.gz
fixing pkgbuild and making it a true git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05b75689478e..cd2a0af5a565 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-pkgbase=('python-gmusicapi-git')
-pkgname=('python-gmusicapi-git')
+#Maintainer: Solomon Choina <shlomochoina@gmail.com>
-pkgver='11.0.0'
+pkgname='python-gmusicapi-git'
+pkgver=12.1.1.r3.g57f84b6
pkgrel=1
pkgdesc="An unofficial api for Google Play Music."
@@ -27,12 +27,18 @@ depends=(
'python-protobuf>=3.0.0'
'python-decorator>=3.3.1'
)
+
makedepends=('python-setuptools' 'git')
license=('BSD')
arch=('any')
-source=("${pkgname}::git+$url#tag=${_gitver}")
+source=("${pkgname}::git+$url")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "${pkgname}"
python setup.py build