summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroysstu2018-07-14 15:33:30 +0200
committeroysstu2018-07-14 15:33:30 +0200
commit2fdc6761725b76366d4a8c4a8b13127a65b729d7 (patch)
treedbc19bdd15e0627f7496aecb862fab771800d9c1 /PKGBUILD
downloadaur-2fdc6761725b76366d4a8c4a8b13127a65b729d7.tar.gz
v1.9.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..595fadbded13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Oystein Sture <oysstu@gmail.com>
+# Contributor:
+
+pkgname=python-gpy
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Gaussian processes framework in python"
+arch=("any")
+license=("BSD")
+url="https://github.com/SheffieldML/GPy"
+depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-paramz' 'python-matplotlib')
+optdepends=('python-plotly' 'ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook' 'python-mpi4py')
+makedepends=('python-setuptools' 'python-numpy')
+source=("https://github.com/SheffieldML/GPy/archive/v${pkgver}.tar.gz")
+sha512sums=("50dc3627a05b9fc2fbc61204cf492e89d5c067da7aca3e738c52cc3c06652aa825e27e66b0a14a2e67e074cd19a75ab564449a762f1de1ba27a02fc986432403")
+
+build() {
+ cd "GPy-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "GPy-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-gpy/LICENSE"
+}