summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Schaf2015-06-08 20:08:37 +0200
committerPhil Schaf2015-06-08 20:08:37 +0200
commit163d1e11cf0b6821b10dae08b7be168691f5e5ff (patch)
treee56bba19fc0291f812a7036266fd3da407b8e484 /PKGBUILD
downloadaur-python-graph.tar.gz
aur4 migration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0f411e099df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+pkgname=python-graph
+pkgver=1.8.2
+pkgrel=3
+pkgdesc='python-graph is a library for working graphs in Python'
+arch=('any')
+url='https://github.com/pmatiello/python-graph'
+license=('MIT')
+depends=('python' 'python-distribute' 'python-pydot')
+source=(
+ "https://pypi.python.org/packages/source/p/python-graph-core/python-graph-core-$pkgver.tar.gz"
+ "https://pypi.python.org/packages/source/p/python-graph-dot/python-graph-dot-$pkgver.tar.gz")
+md5sums=(
+ '16f177496beb6e6bc507b12b8346ff96'
+ '0ecd251a9fd210a9135e1d1957689709')
+
+package() {
+ cd "$srcdir/python-graph-core-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ cd "$srcdir/python-graph-dot-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file