summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTrougnouf (Benoit Brummer)2024-04-02 21:16:20 +0200
committerTrougnouf (Benoit Brummer)2024-04-02 21:16:20 +0200
commitdefa39da068faea7fef2da4b2e59304c2fa1509e (patch)
tree8247e41a9568bed77fbfd97b6f51ed74adce0aea /PKGBUILD
downloadaur-python-h3.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..692fe3f54356
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Benoit Brummer (Trougnouf) <trougnouf@gmail.com>
+
+_name='h3-py'
+pkgname=('python-h3')
+pkgdesc="Hexagonal Hierarchical Geospatial Indexing System in Python"
+pkgver=3.7.7
+pkgrel=1
+url="https://github.com/uber/${_name}"
+license=('Apache')
+arch=('any')
+depends=('python' 'cython')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-scikit-build' 'cmake' 'flake8' 'python-cmake-build-extension' 'python-setuptools')
+source=("git+${url}.git#tag=v${pkgver}")
+sha256sums=('c6b42cfc785d4c43830be52be99bafedafcaee7cb8dd059e8448ce558516008a')
+
+prepare() {
+ cd "${srcdir}/${_name}"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "${srcdir}/${_name}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}