summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgesh2024-04-15 20:40:03 +0300
committergesh2024-04-15 20:40:03 +0300
commit11fd01148573d20c4e83a8a89ba6b048461dbe30 (patch)
tree90b80c563afa3dade2afc2717f27011ac61ff7b9 /PKGBUILD
parent524d1ae778931530648743585016c3bd88bcb2a1 (diff)
downloadaur-python-habanero.tar.gz
Install licenses, add optdep
The MIT license provided has a copyright line, so needs installation in particular
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d790cc5cd8be..0edeb14e6d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname='python-habanero'
_module='habanero'
_src_folder='habanero-1.2.6'
pkgver='1.2.6'
-pkgrel=1
+pkgrel=2
pkgdesc="A low level client for Crossref's Search API"
url="https://github.com/sckott/habanero"
depends=(
@@ -18,7 +18,10 @@ makedepends=(
'python-setuptools'
'python-setuptools-scm'
)
-license=('MIT')
+optdepends=(
+ 'python-bibtexparser: attempt to fix misformatted bibtex'
+)
+license=('LicenseRef-MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/3d/17/885ee33738a7ecb29d487ca42043378804d0c47945d24ee040cfaa35beeb/habanero-1.2.6.tar.gz")
sha256sums=('b206d49f44f41c2289f0ad731f259a50d4376c747d8ecbb219a73874d45309d4')
@@ -31,6 +34,7 @@ build() {
package() {
cd "${srcdir}/${_src_folder}"
python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}
# vim:set ts=2 sw=2 et: