summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDennis Fink2017-03-27 18:24:12 +0200
committerDennis Fink2017-03-27 18:24:12 +0200
commit557f38d836a64bd3af1386a38707bc00c1f5b7fd (patch)
tree51f6bf2a5511ca6b953b8f74263a6218a36adb72 /PKGBUILD
downloadaur-python-hddtemp.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5b1605ec0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Dennis Fink <dennis.fink@c3l.lu>
+
+pkgname=python-hddtemp
+_pkgname=hddtemp
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Python library to parse hddtemp data"
+arch=('any')
+url="https://pypi.python.org/pypi/hddtemp"
+license=('GPL3')
+depends=('python')
+source=(https://pypi.io/packages/source/h/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha512sums=('6e38de26b06a60089176fed29385a5370ed76cb79eccdeda9277fcd7ce16285dbc13e8493eb05cfbed0a991cabd837668ee6c1bdce4f304a6b2922e89d03990b')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et;