summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Henrie2023-10-25 16:58:32 -0600
committerAlex Henrie2023-10-25 16:58:32 -0600
commit0f3ce253692a7e731b4bb9ab2847e6c3a4acd157 (patch)
treec2ff00a5cebec062cd6c302341ce12f49ee8ed88 /PKGBUILD
downloadaur-python-hilbertcurve.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db093914dfa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
+_name=hilbertcurve
+pkgname=python-$_name
+pkgver=2.0.5
+pkgrel=1
+pkgdesc='Converts between one-dimensional distance along a Hilbert curve and n-dimensional points'
+arch=('any')
+url='https://github.com/galtay/hilbertcurve'
+license=('MIT')
+depends=('python-numpy')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('6a7703d9a2f1fe748c86d86908bf183e7d139b973645e4b2526e10b34e75796d')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}