summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author71e6fd522018-01-06 09:58:41 +0800
committer71e6fd522018-01-06 09:58:41 +0800
commitbf5b75a1c56298865392d7d475072f4648470bd9 (patch)
treee8dcc774c27dee08b8bdb871c7d7b5152528ff00 /PKGBUILD
downloadaur-python-hoedown.tar.gz
python-hoedown
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23a2eb7fa1f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: 71e6fd52 <DAStudio.71e6fd52@gmail.com>
+
+pkgbase=('python-hoedown')
+pkgname=('python-hoedown')
+_module='hoedown'
+pkgver='0.2.3'
+pkgrel=1
+pkgdesc="The Python binding for Hoedown, a markdown parsing library."
+url="https://github.com/hhatto/python-hoedown"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/h/hoedown/hoedown-${pkgver}.tar.gz")
+md5sums=('cb1c5e620eb277deabb3345012bc387f')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}