summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2022-06-10 13:26:30 -0400
committerGuillaume Horel2022-06-10 13:26:30 -0400
commit64b7af4f6b30df632d105169e5a4aa3ae12bfbd0 (patch)
tree0b99989db64c193470c9ddad91e245a7b9529211 /PKGBUILD
parenta87dd8267b886381a98fd4bcd1398ec1d86021d7 (diff)
downloadaur-python-ibis.tar.gz
bump to 3.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b6c8f9da04a..68a59785ca1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,38 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-ibis
-_pkgname=ibis
-pkgver=0.13.0
+_pkgname=ibis-framework
+pkgver=3.0.2
pkgrel=1
pkgdesc="A pandas-like deferred expression system, with first class SQL support"
arch=('any')
url="https://github.com/ibis-project/ibis"
license=('Apache')
-depends=('python' 'python-multipledispatch' 'python-numpy' 'python-pandas' 'python-regex' 'python-toolz')
+depends=('python-multipledispatch' 'python-numpy' 'python-pandas' 'python-pydantic' 'python-regex' 'python-toolz')
checkdepends=('python-pytest')
optdepends=()
makedepends=('python-setuptools')
-source=("https://github.com/ibis-project/ibis/archive/v$pkgver.tar.gz")
-sha256sums=('3da1b51c72e074183abb08a2724a5b77f90e7328ab014de5ff7e699daf5c75f9')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('5051b56d125ef0f64375f5dc98873d3238736dd09a4b7aa615c0b40368f362d4')
+
+build(){
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
package(){
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
}
#check(){
-# cd "$srcdir/$_pkgname-$pkgver/ibis"
-# py.test
+ #local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+
+ #cd "$_pkgname-$pkgver"
+ #python setup.py install --root=test_dir
+ #export PYTHONPATH="test_dir/$_site_packages:$PYTHONPATH"
+ #rm ibis/tests/test_version.py
+ #mv test_dir/$_site_packages/ibis{_framework,}-${pkgver}-py3.10.egg-info/
+ #pytest
#}
# vim:ts=2:sw=2:et: