summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamLukeYes2021-09-10 13:36:48 +0800
committerSamLukeYes2021-09-10 13:36:48 +0800
commitc7d5fce0302c991d094b420f8e23d01eb81253a9 (patch)
treed6f2c16e23a22c321e11d14837b2b405f488cddd /PKGBUILD
downloadaur-python-imgaug-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57f50b132c79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sam L. Yes <samlukeyes123 at gmail dot com>
+# Modified from python-imgaug
+# Contributor: dianlujitao <dianlujitao at gmail dot com>
+
+pkgname=python-imgaug-git
+pkgver=0.4.0.r41.g0101108d
+pkgrel=1
+pkgdesc="Image augmentation for machine learning experiments"
+url="https://github.com/aleju/imgaug"
+depends=('python-opencv' 'python-six' 'python-numpy' 'python-scipy' 'python-scikit-image')
+makedepends=('python-setuptools' 'git')
+provides=('python-imgaug')
+conflicts=('python-imgaug')
+license=('MIT')
+arch=('any')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd $srcdir/imgaug
+ sed -i '/"opencv-python-headless",/d' setup.py
+}
+
+pkgver() {
+ cd imgaug
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/imgaug
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/imgaug
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}