summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212024-11-22 09:13:19 +0100
committera8212024-11-22 09:13:19 +0100
commit3004097e26f7d8a665d91e0cbe05eba1abb474cb (patch)
tree90aa30ad7a717fd1a6b01b73fa46745cd9ac3706 /PKGBUILD
parent9769f292a23d17bd947c0b06dcd12d503fae75ce (diff)
downloadaur-python-ipython-sql.tar.gz
Update to PEP-517
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 703fb201df90..6d854d0c0745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=python-ipython-sql
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="RDBMS access via IPython"
arch=('any')
url="https://pypi.python.org/pypi/ipython-sql"
license=('MIT')
depends=('ipython' 'python-sqlalchemy' 'python-prettytable' 'python-sqlparse' 'python-six')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/i/${pkgname#python-}/${pkgname#python-}-$pkgver.tar.gz")
sha256sums=('3db3ce7f9a95dfaf43876fa80b16bdbb9a04de0ba12042cab13e9f596fcffdbe')
optdepends=(
@@ -20,13 +20,14 @@ optdepends=(
build() {
cd "${pkgname#python-}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname#python-}-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/$pkgname/" *.rst
}
# vim: set ts=4 sw=4 et: