summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Forencich2015-07-20 12:18:24 -0700
committerAlex Forencich2015-07-20 12:18:24 -0700
commitbd83a04c9fd6673495ace190914c7103c1fcfa11 (patch)
treec6d7b40052d1132a3cf5a0faf52c0d25e677bb09 /PKGBUILD
downloadaur-python-ivi.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..852457f004bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Forencich <alex@alexforencich.com>
+pkgname=python-ivi
+pkgver=0.14.9
+pkgrel=1
+pkgdesc="Python Interchangeable Virtual Instrument Library"
+arch=('any')
+url="https://github.com/python-ivi/python-ivi"
+license=('MIT')
+depends=('python' 'python-numpy')
+optdepends=(
+ 'python-vxi11: VXI11 instrument support'
+ 'python-usbtmc: USBTMC instrument support'
+ 'python-pyvisa: PyVISA interface for NI drivers'
+)
+
+source=("python-ivi-$pkgver.tar.gz::https://github.com/python-ivi/python-ivi/archive/v$pkgver.tar.gz")
+md5sums=('86d4e627d9cb328bb11b1d836b68baee')
+
+build() {
+ cd "$srcdir/python-ivi-$pkgver"
+}
+
+package() {
+ cd "$srcdir/python-ivi-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+