summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-05-10 22:25:58 +0200
committerGoliathLabs2020-05-10 22:25:58 +0200
commitbe44141256f17129d1b6bd30b82f3ec006c7e4ad (patch)
tree96e639cdc7a833608f07f6c0d42d123125e288bc /PKGBUILD
downloadaur-python-jadi.tar.gz
Added: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2ff8aa85037
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+
+pkgname=python-jadi
+_pkgname=jadi
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Minimalistic IoC for Python"
+arch=("any")
+url="https://github.com/ajenti/jadi"
+license=('LGPLv3')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/ajenti/jadi/master/LICENSE")
+sha256sums=('6321ff8aea7b4de7a279d866baada9fb37daf7caf0198151747cf78b9ac96d1f'
+ '97628afebc60f026f5c2b25d7491c46a5c4ee61f693e7cfa07fbd2c03605979b')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 ../LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}