summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYacob Zitouni2021-08-23 12:19:55 +0200
committerYacob Zitouni2021-08-23 12:19:55 +0200
commit41b3c05f8381031a46091f31fe6e62016d72d613 (patch)
tree8dbd476a72deda0d2c1e64a9499c64dbbc0843d1 /PKGBUILD
parent994b7d3b66e714c9f80a09168c30298fc0f636b1 (diff)
downloadaur-python-jproperties.tar.gz
Fixed depends and update to 2.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aed8af286d12..2768039099ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,31 @@
pkgname=python-jproperties
_name=jproperties
-pkgver=2.1.0
+pkgver=2.1.1
pkgrel=1
pkgdesc="Java Property file parser and writer for Python"
url="https://github.com/Tblue/python-jproperties"
-depends=('python3')
-makedepends=('python3' 'python-setuptools')
+depends=('python3' 'python-six')
+makedepends=('python-setuptools' 'python-setuptools-scm' "python-pytest")
license=('BSD' 'Python')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('504d7b8d3b2f5f0f52c22c1f72bd50576dca17b01b4cd00d4359c6b0607a59ce')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "setuptools_scm-version.patch")
+sha256sums=('40b71124e8d257e8954899a91cd2d5c0f72e0f67f1b72048a5ba264567604f29'
+ '901c1b8861c700dcdbf8f462ab21e8039061f87216c0b73872c8e4e2982f4f48')
+
+prepare() {
+ cd $srcdir
+ patch --forward --strip=1 --input="$srcdir/setuptools_scm-version.patch" # Fix issue https://github.com/Tblue/python-jproperties/issues/15
+}
build() {
- cd $srcdir/jproperties-$pkgver
+ cd $srcdir/$_name-$pkgver
python setup.py build
}
package() {
- cd $srcdir/jproperties-$pkgver
+ cd $srcdir/$_name-$pkgver
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python setup.py install --root="$pkgdir" --optimize=1
}