summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormarty18852024-09-29 15:54:25 +0800
committermarty18852024-09-29 15:54:25 +0800
commit39025b968728cd2ebd63881644ef30a3dade1f66 (patch)
tree90f01dca72cad96e8d09710049b1d8978d7e54bd /PKGBUILD
downloadaur-python-jsons.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc17375d7d89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Martin Chang <marty188586@gmail.com>
+
+pkgname=python-jsons
+pkgver=1.6.3
+pkgrel=1
+pkgdesc="A Python lib for (de)serializing Python objects to/from JSON"
+arch=('any')
+url='https://github.com/ramonhagenaars/jsons'
+license=('MIT')
+makedepends=(python-build python-installer python-wheel)
+depends=(python-typish)
+provides=("python-jsons")
+source=("jsons::git+https://github.com/ramonhagenaars/jsons#tag=v$pkgver")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd jsons
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd jsons
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd jsons
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}